질문: 티스토리 백업기능 삭제 이후 백업 데이터 요청시 백업 가능한지 문의드리고 싶습니다.


백업기능이 조만간 삭제된다는 공지를 봤는데요 


현재도 블로그 용량이 너무 크면 저걸로 백업이 안되고 별도 문의 시에만 가능한 걸로 아는데 (즉, 별도 문의 시에 백업 데이터를 제공하는 걸로 알고 있는데) 


이 기능이 삭제된 이후에도 고객센터에 문의를 하면 지금처럼 백업 데이터를 받아볼 수 있는지 궁금합니다. 


만약 이것이 안 된다면, 앞으로 서비스가 종료되면 블로그에 지금까지 썼던 모든 포스팅과 자료들이 날아간다는 건데 


이용자 입장에서는 매우 불안할 수밖에 없네요 


지금까지는 서비스 종료 공지가 나온다면 종료되기 전에 알아서 백업을 받아갈 수 있었는데, 이제 백업기능 삭제하고 나면 개인이 백업을 받는 것이 불가능해지는데 


어떻게 하실 건가요? 


최소한 요청자에 한해서는 백업 데이터를 제공하는 것이 좋다고 생각됩니다만.. 


한편으로 그렇게 되면 백업 데이터 요청이 쇄도하게 될 텐데, 지금도 고객센터 일처리가 굉장히 미흡한게 사실인데 그 상황이 되면 그 수많은 요청들을 일일히 처리할 수 있다고 보시나요? 


또한, 솔직히 기대는 안 하고 있습니다만, 차후에 (최소한 서비스가 종료되기 이전에 백업/복구 기능을 보완해서 다시 도입하실 계획은 있으신가요? 




문의사항을 정리하면 다음과 같습니다. 


1. 백업기능 삭제 이후에도 고객센터에 문의하면 백업데이터 제공이 가능한지? 

2. 서비스가 종료되고 나면 이용자들의 데이터는 어떻게 처리하실 생각인지? (이용자들에게 백업 데이터를 제공하실 건지, 아니면 그냥 서비스 종료와 함께 블로그의 모든 자료들이 날아가는 걸 눈 뜨고 지켜볼 수밖에 없는건지) 

3. 서비스 종료시에 쇄도하게 될 각종 문의사항은 원활하게 응대가 가능할 수 있을지? (까놓고 말해서 지금 엉망진창인 고객센터 수준에서 그걸 어떻게 처리하실 건지?) 

4. 백업기능 삭제 이후에 해당 기능을 보완해서 다시 추가할 예정은 있는지? 만약 있다면 언제쯤 가능한지? 




쓰다 보니 어쩌다가 티스토리 조만간 망한다는 투로 작성하게 됐는데, 어차피 다음에서 티스토리를 조만간 정리할 예정인건 누구나 다 아는 사실이므로 노골적으로 작성했습니다. 수많은 티스토리 이용자들이 서비스 종료 이후에 데이터를 모두 날릴 걱정에 불안해하고 있는데, 백업 기능이 삭제되고 나면 앞으로 더 이상 백업자료를 받아볼 수 없게 되는지 불안해서 문의드립니다. 답변 부탁드립니다.



---


답변: (담당자 이름이나 앞뒤 쓸데없는 부분은 삭제함)


1. 백업 기능 종료 후에는 고객센터로 요청하셔도 백업 파일을 제공해 드릴 계획이 없습니다.


2. 티스토리는 서비스 종료 계획이 없습니다. 

  이에 서비스 종료 시점에 기존 데이터를 어떻게 제공해 드릴지에 대해서도 검토된 적이 없습니다. 


  다만, 그런 상황이 발생할 경우

  어떤 형태로든 백업 등에 대해서 검토할 예정이니 안심하고 티스토리를 이용해 주시기 바랍니다.


3. 2번 답과 마찬가지로 서비스 종료를

  검토하고 있지 않은 상황에서 관련 답변을 드릴 수는 없을 것 같습니다.


4. 백업 기능 대체 등에 대해서는

  내부적으로 검토 중에 있으며 정책/방식 등에 대해 결정 시 공지드릴 예정입니다.



---


한 줄 요약: 티스토리 이용자 여러분, 티스토리는 안전합니다! 안심하고 이용해 주십시오!




(그림판 발퀄 ㅈㅅ)





하...


자, 하나하나 살펴보도록 하자.


우선 고객센터 어쩌고는 솔직히 그냥 까고 싶어서 넣은 부분이고, 중요한 것은 


  1. 백업기능 종료시에 이사가고 싶으면 백업데이터 챙길 수 있나? -> X
  2. 나중에 백업기능 새로 정비해서 재도입할거냐? -> 사실상 X
  3. 티스토리 망하면 어떻게 할래? 데이터 날림? -> 이용자 여러분 안심하십시오!


결국 결론은, 혹시라도 나중에 워드프레스 등 개인 호스팅으로 옮기고자 하는 사람은 지금 당장 선택해야 한다는 사실이다.


앞으로 백업 데이터를 아예 제공하지 않겠다고 했으니, 이사라도 가려면 네이버처럼 일일히 수동으로 옮기던가 해야 한다. WTF? 사실상 못한다고 보면 될듯. 즉, 지금 안가면 앞으로 못 간다.


사실상 망해가는 티스토리에 계속 몸담고 있어야 하나? 이 부분은 설치형 블로그와 티스토리의 장단점을 고려해서 개인이 각자 알아서 판단해야 한다. 본인 같은 경우 이미 사이트 하나를 운영중이기 때문에 한쪽 구석에 꼽사리 껴서 WP 설치하면 되긴 하지만, 대다수의 일반 이용자들은 무료 호스팅을 받는다고 해도 제약이 많다.


그렇다면, 티스토리를 계속 쓰고 싶은 사람은? 그나마 여기서 한 가지 다행인건, 티스토리 문 닫을 경우 데이터에 대해 최소한 검토라도 하겠다는 거다. 일단 자기들이 말을 저렇게 해 놨으니, 어느 정도는 믿고 써도 되지 않을까 싶다.


다만, 중요한건 이것 또한 확정적으로 보장하는 건 아무 것도 없다는 사실이다. 검토만 한다고 했지, 확실하게 블로그 데이터를 보장해준다고 한 적은 없다. 즉, 최악의 경우 조만간 티스토리 망하고, 그동안 써 왔던 글도 하나도 못 챙기고 허망하게 날려버릴 수도 있다는 사실이다.




2010년대 중반 넘을수록 점점 마음에 들지 않는 행보만을 보여주는 티스토리, 이제는 백업 기능까지 삭제하고 더 이상 백업 데이터도 제공하지 않겠다고 함으로써 블로그 포장이사의 가능성마저 봉인시켜 버렸다. 이젠 진짜 결정할 때인거 같다. 일말의 희망을 붙잡고 계속 이용할 것인지, 아님 빨리 탈출할 것인지.


21일까지다. 이제 정말 얼마 남지 않았다. 그 이후로는 탈출하고 싶어도 더 이상 탈출하지 못하고 끝까지 남아야 한다. 이용자들은 각자의 사정과 향후 전망을 고려하여 현명한 선택을 해야 할 것이다.

저작자 표시 비영리 동일 조건 변경 허락
신고
크리에이티브 커먼즈 라이선스
Creative Commons License

특정 기종에서 되는지 안 되는지는 제가 그걸 써보지 않았기 때문에 알 수 없습니다. 만약 본인이 쓰는 기기와 호환이 되는지 안 되는지 모를 경우, 먼저 디벨로이드 등 안드로이드 사용자 커뮤니티에서 본인의 폰/태블릿 기종명으로 검색해서 후기를 찾아보고 난 후에 해보시기 바랍니다.




최종 수정일: 17.07.20. Magisk 버전 v13.3, Magisk Manager 앱 버전 v5.1.1 기준


# 17.06.02. 몇시간 전에 Magisk Manager 앱이 (구글 정책 위반으로) 플레이스토어에서 내려갔기 때문에, apk 파일 직접 다운로드 링크로 변경합니다. 기존에 플레이스토어에서 설치하셨던 분들은 참고하시기 바랍니다.




Magisk 공식 XDA 쓰레드: http://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445


(# 저는 개발자가 아닙니다. 이하의 내용은 전부 위 쓰레드의 내용을 바탕으로 한국의 초보 유저들이 이해할 수 있도록 작성한 글입니다. Magisk의 개발자는 XDA의 "topjohnwu" 님입니다.)




* 백업은 항상 필수입니다!


** 루팅과 SuperSU는 다릅니다. SuperSU랑 "su 바이너리" 도 다릅니다. 질문하시기 전에 반드시 기본 개념을 숙지해 주세요!! 아래 다 설명해놨습니다. 반드시 본문 내용을 필독해주세요. 




0. 시작하기 전에 먼저 알아야 할 것들(필독)


1) Magisk란 무엇인가?


- Magisk는 각종 Systemless 모듈들을 설치하고 관리하기 위한 종합 systemless 매니지먼트 도구입니다. 이를 바탕으로 루팅을 비롯한 각종 Systemless 모듈(=Magisk 모듈)들을 설치할 수 있습니다.


추가: 버전 11부터는 Magisk 자체가 루팅 툴이기도 합니다.(MagiskSU라고 합니다.) 즉, Magisk 안에 su가 내장되어 있고, 매니저 앱으로 루팅권한을 관리할 수 있습니다. 또한 클로즈드 소스인 SuperSU와는 달리, 오픈소스입니다.


* 따라서, 현재 Magisk를 설치하면 자동으로 루팅이 됩니다. 즉, Magisk는 Systemless 루팅 툴이자 동시에 여러 Magisk 모듈 매니지먼트 툴입니다.


또, 이를 바탕으로 루팅 감지를 우회하고 SafetyNet을 통과하도록 하는 "Magisk Hide" 기능을 제공합니다. 이를 바탕으로 여러 루팅 감지앱을 우회할 수 있습니다.


* v12.0 추가: Magisk Hide에 삼성의 KNOX 변조 상태를 0x0 (변조가 안 된 상태)로 속일 수 있는 기능이 추가되었습니다. 이를 바탕으로, 삼성페이나 프라이빗 모드와 같이 녹스 변조상태를 확인하는 앱들의 정상 작동이 가능해질 것으로 예상됩니다.


그 외 다양한 특징 및 기능 안내는 위 Magisk 공식 쓰레드를 참고하세요.



2) Systemless란 무엇인가?


- 우리가 사용하는 안드로이드 OS는 핸드폰의 /system 폴더 이하에 설치됩니다. 기존에 존재하는 (루팅을 비롯한) 각종 트윅 모드들은 바로 이 system 폴더 이하 내용물을 추가하거나 변경/삭제하는 등의 작업을 거칩니다. Systemless는 바로 저 /system 폴더를 건드리지 않고도 각종 트윅을 가능하게 하는 것을 말합니다.  


이로 인해 얻을 수 있는 장점은 크게 다음과 같습니다.


  • 깔끔하고 안전하다: system 폴더를 건드리지 않기 때문에, 뭔가가 잘못되더라도 쉽게 원상복구가 가능합니다. 부팅이 안 되더라도 magisk 언인스톨 파일만 설치하면 복구가 가능합니다.
  • OTA 업데이트가 가능하다: (이 부분은 삼성 갤럭시 등에는 해당 안됩니다.) system 영역을 건드리지 않기 때문에 OTA 업데이트가 가능하고, 업데이트 이후에도 트윅이 그대로 남아 있습니다.
  • 쉽고 편하다: Magisk 하나만 설치하면 끝입니다. 일일히 /system 폴더를 수정하거나 할 필요 없이 Magisk 매니저 앱에서 각종 모드를 쉽게 설치/삭제할 수 있고 관리할 수 있습니다.
  • Magisk Hide: Magisk 매니저 앱에서 루팅을 비롯한(Xposed는 제외) 각종 Magisk 모듈들을 특정 앱들로부터 숨겨줄 수 있습니다. 이를 통해 시스템 변조를 확인하는 여러가지 앱들의 우회가 가능합니다.



3) Magisk를 설치하기 위한 기본사양 (v13.1 기준)


- 안드로이드 5.0 이상이어야 합니다. (4.4 이하는 불가능)


- 본인 기기의 기종에 맞는 커스텀 리커버리가 설치되어 있어야 합니다. (없으면 검색해서 설치하시기 바랍니다)


- 다음의 경우에는 설치가 안되거나 제한될 수 있습니다.

  • 픽셀/픽셀 XL: 작업중이라고 합니다.
  • 몇몇 Asus 기기들: boot image singing이 필요하다고 합니다.
  • 소니 기기들은 부트로더 언락이 필요할 수 있습니다.
  • Magisk Hide 기능을 사용하려면 리눅스 커널 버전 3.8 이상이어야 합니다. 단, 중요 기능들을 백포팅한 커널의 경우 하위 버전이더라도 작동할 수 있습니다. (아래 3-1 "루팅 감지앱 우회하기" 참고)


- 설치 이전에 모든 루팅 및 기타 /system 수정내역을 초기화시켜야 합니다. 이 부분은 설치과정에서 다시 언급하겠습니다.




1. 설치 준비물 - 최초 설치 기준(모두 받으세요. 반드시 최신버전으로 받으세요)


- Magisk: http://tiny.cc/latestmagisk


- Magisk Manager app: http://tiny.cc/latestmanager


- 언루팅 파일 (SuperSU 사용중인 경우 다운받으세요): http://forum.xda-developers.com/showpost.php?p=63615067


* Magisk 언인스톨러: http://tiny.cc/latestuninstaller




2. 설치과정 + 삭제방법 (기존에 설치한 적이 없는 경우)



0) 언루팅하기 및 기타 모드들 삭제하기 (순정롬을 사용중이고 루팅이나 xposed 기타 모드들을 설치한 적이 없다면 생략해도 됩니다.)


0-1) SuperSU 사용자의 경우: 다운받은 unSU 파일을 리커버리에서 설치해서 언루팅을 시켜줍니다.


(* 사실 SuperSU와 Magisk는 동시에 사용이 가능하긴 합니다. 다만 후술할 Magisk Hide 기능 사용이 불가능하고, 제가 볼때 SuperSU를 굳이 고집해야 할 이유가 없기 때문에, 혼동을 막기 위해 그냥 언루팅하는 것이 낫다고 생각해서 이렇게 설명합니다.)


0-2) 리니지OS 사용자이고, 리니지OS 기본 su를 사용중인 경우: 아래 3-0번으로 넘어가주세요. (언루팅할 필요 없음)


(* 리니지OS를 사용중이지만 루팅이 되어있지 않은 경우는 아래 1번대로 진행해야 합니다.)


0-3) Xposed를 사용중인 경우: xposed 언인스톨러 파일을 이용해서 삭제를 진행합니다. (언인스톨러 파일은 xposed 인스톨러 앱에서 다운받을 수 있습니다.) 기타 모드를 설치한 경우에도 역시 (해당 개발자/배포자의 글을 참고해서) 삭제를 진행합니다. 


* 만약 기존에 램디스크 패치를 진행하는 등 부트이미지를 건드린 적이 있을 경우: 건드리기 전의 순정 부트이미지로 복구하시기 바랍니다. (이게 무슨 말인지 모르겠다면 해당사항이 없을 가능성이 큽니다. 부트이미지 건드린 적이 있는 분이라면 본인 스스로 잘 아실 겁니다.)



1) Magisk 설치하기(+루팅하기)


- 리커버리에서 다운받은 magisk-v(숫자).zip 파일을 설치하고 재부팅합니다. 그 다음, 위에서 다운받은 Magisk Manager 앱을 설치합니다.


(* 참고: v10부터 magisk 설치파일에 root가 포함되어 있으므로 따로 phh's superuser zip파일을 설치할 필요가 없습니다. v11부터는 Magisk에 SU가 완전히 통합되었으므로, Magisk 하나만 설치하면 됩니다. 루팅 매니저 앱 또한 통합되었습니다.)


* 이때 설치가 안된다면: 사용하고 있는 롬/커널이 Magisk와 호환이 안 되는 것입니다. 위 0-3번 확인해보시고, 만약 커스텀 롬/커널 사용시에는 커널이 램디스크 패치를 지원하지 않을 경우 Magisk 설치가 되지 않습니다. 다른 (램디스크 패치를 지원하는) 커널을 사용할 경우 설치가 될 수 있으니 커널을 바꿔보세요.


* 설치하고 나서 벽돌이 되었을 경우: 리커버리 모드로 부팅하고, 위에서 다운받은 언인스톨러 파일을 설치합니다. (이 경우 해당 기기와 호환이 되지 않을 가능성이 높습니다.)



2) (선택) Xposed를 비롯한 각종 Magisk 모듈 설치하기


- (Xposed를 설치할 경우) 먼저 다음의 링크에서 Metarial Design Xposed Installer 앱을 설치합니다. (기존의 공식 xposed installer 앱이 설치되어 있을 경우 삭제하고 설치합니다. http://forum.xda-developers.com/xposed/material-design-xposed-installer-t3137758


* 꼭 설치하세요! 자세히 안 읽고 (공식 인스톨러만 설치하고) 질문하는 분들이 많은 것 같아서 다시 강조합니다. 반드시 (공식 인스톨러는 삭제하고) 저 인스톨러 앱을 설치하세요!


그 다음 Magisk 매니저 앱을 열고 Downloads 탭으로 들어간 다음 목록에서 다운받고 설치하고 나서 재부팅하면 됩니다. (참고로 안드로이드 5.0: SDK 21, 5.1: 22, 6.0: 23 입니다.) 


* 참고: 이 Magisk용 Xposed 프레임워크는 갤럭시용/ARM64용 등이 모두 통합된 버전입니다. 따라서 갤럭시든 뭐든 구분할 필요 없이 설치 가능합니다.


다른 모듈들 또한 마찬가지 방식으로 설치하면 됩니다. 사용중지 처리하거나 삭제하고 싶은 경우, Modules 탭에서 체크를 해제하거나 휴지통 아이콘을 누르고 재부팅하면 됩니다.



3) Magisk 삭제하기


- 리커버리로 부팅한 다음 다운받았던 언인스톨 zip 파일을 설치해주면 됩니다. Magisk 및 각종 Magisk 모듈들이 전부 삭제되고 설치하기 전으로 초기화됩니다. 만약 Magisk 및 각종 모듈 설치 이후에 부팅이 되지 않을 경우에는 바로 리커버리로 부팅해서 언인스톨하면 됩니다.




3. 기타


0) 이전 버전에서 업데이트하는 경우, 또는 리니지OS (구 CM롬) 기본 루팅 사용자의 경우


- 만약 Magisk v6 이하에서 업데이트할 경우, 언인스톨러를 사용해서 언인스톨한 다음 다시 설치해야 합니다. Magisk v7 이상에서 업데이트하거나 리니지OS 기본 루팅 사용자의 경우, Magisk Manager 앱을 설치하고 실행해서 업데이트를 다운받고 설치 후 재부팅하면 됩니다.


(Magisk Manager 최신 버전을 사용하는 경우, "설정-업데이트 알림"에 체크가 되어 있으면 새 버전이 있을 경우 자동으로 알림이 오므로 설치하면 됩니다.)



1) 루팅 감지앱 우회하기


* 주의사항: 모든 앱이 우회가 되는 것이 아닙니다. 안 되는 앱이 있을 수 있습니다. 또한, Xposed를 감지하는 앱의 경우 우회가 불가능할 수 있습니다. (SuperSU+suhide의 경우는 가능하다고 하는데, 제가 해본 결과는 안되더군요.) 만약 금융앱을 사용하고자 하는 경우, 루팅된 폰에서 금융앱을 이용하는 것은 권장하지 않습니다.


루팅된 폰에서 금융앱을 이용하는 것은 절대 권장하지 않습니다. 저도 루팅된 폰에서 폰뱅킹은 이용하지 않습니다. 반드시 본인 책임 하에 사용하세요.


* 주의사항 2(내용추가): SafetyNet을 사용하는 앱들(안드로이드 페이, 포켓몬고, 슈퍼마리오 런 등등)을 이용하고자 할 경우, (루팅과 상관없이) 롬 자체가 CTS를 pass할 수 있어야 합니다. 다시 말해서, SafetyNet은 루팅 뿐만 아니라 시스템 변조 자체를 감시하기 때문에, 루팅하기 이전에 이미 롬 자체가 CTS를 통과하지 못하는 경우엔 아무리 Magisk를 설치해도 우회하지 못합니다.이를 해결하기 위해서는 SafetyNet 문제를 해결한 커스텀 롬을 사용하시거나, 또는 100% 순정롬 상태에서 이용해야 합니다. 


설정(Settings)에서 "Enable Magisk Hide"를 체크한 다음, Magisk Hide 탭으로 들어가서 우회를 원하는 앱에 체크해줍니다. (해당 앱에서 루팅을 포함한 각종 Magisk 모듈을 감지하는 것을 막아줍니다.)


* v11 내용추가: v11부터는 Magisk Hide 활성화 이후에 재부팅할 필요가 없습니다. 단, 본인이 Magisk 기본 SU (MagiskSU) 사용자가 아니라 SuperSU 사용자일 경우, Maigsk Hide로는 제대로 우회가 되지 않고, suhide를 사용해야 할 수 있습니다. suhide 사용법은 여기서 다루지 않으므로 다른 곳에서 검색해보세요.


# Magisk Hide가 작동하지 않을 경우: 리눅스 커널 3.8 미만의 기기를 사용할 경우, Magisk Hide에 필요한 기능이 들어있지 않아서 작동하지 않을 수 있습니다. 본인이 사용하는 기기의 커널 버전을 확인해 보세요.


(커스텀 커널을 비롯한 일부 커널의 경우 백포팅이 되어 있을 수 있습니다. 만약 본인이 순정롬이나 순정 커널을 사용하고 있었고, 커스텀 커널 자료가 있을 경우, 해당 커스텀 커널에서 Magisk Hide가 작동하는 지 확인해 보고 설치해 보세요.)



2) 커스텀롬 업데이트 시 조치사항


- CM13이나 Lineage OS 등의 롬을 사용할 경우, 롬 업데이트 과정에서 Magisk가 수정해 놓은 부트 이미지가 원상복구되므로 다시 설치해야 합니다. 


2-1) 롬에 리니지os 기본 su가 포함되어 있는 빌드인 경우: 롬을 설치하고 나서, Magisk Manager 앱을 통해 Magisk를 다시 설치합니다. (위 0번과 같음) 또는, https://download.lineageos.org/extras 에서 su removal 파일을 받은 다음, 롬을 설치할 때 같이 설치하고 마지막에 magisk-v(숫자).zip 파일을 설치합니다.


2-2) SuperSU가 기본 내장된 롬인 경우: 롬을 설치한 후에 위 설치과정 0~1번 과정을 반복해줍니다. (매니저 앱은 이미 설치했으므로 재설치할 필요 없습니다) 롬을 설치할 때 unSU 파일도 같이 설치한 다음 마지막에 magisk-v(숫자).zip 파일을 설치해도 됩니다.


2-3) su가 포함되어 있지 않은 롬인 경우(루팅이 안 되어 있는 롬인 경우): 롬(+커널) 설치 후에 맨 마지막에 위 설치과정 1번처럼 magisk-v(숫자).zip 파일을 설치합니다. (커널 설치 전에 Magisk를 설치하면 안됩니다.)


- Magisk 모듈 등의 경우, /data 파티션을 wipe 하지 않는 이상(Dirty flash) 다시 설치할 필요는 없습니다. 다만, 롬 설치 전에 풀 와입(Full wipe, /data 파티션을 포함해서 전부 wipe 하는 것)을 했을 경우, 모듈까지 새로 설치해야 합니다.



3) phh's SuperUser, MagiskSU 대신에 SuperSU를 사용하는 방법 (권장하지 않음)



# 주의: 이하 내용은 오래되었습니다. v10.2 이하 기준이고, 현재 v11 이후 버전의 경우 


1) 먼저 Systmeless 모드로 SuperSU를 설치하고, 

2) 위 링크에서 Magisk Manager 앱을 받은 다음 설치하면 됩니다.


이하 내용은 참고하시라고 남겨둡니다.



* 많은 초보분들이 혼동하는 사실인데, SuperSU와 phh's SuperUser는 다릅니다. 또한, 루팅=SuperSU도 아닙니다. (루팅은 su 바이너리를 설치하고 매니지먼트 앱을 통해 루트권한을 획득하는 것을 말합니다.) SuperSU는 Chainfire라는 분이 개발한 루팅 매니지먼트 도구이고, phh's SuperUser는 마찬가지로 phhusson 이라는 분이 개발한 루팅 도구입니다.


개인적으로 SuperSU는 클로즈드 소스이고, 현재 중국회사에 팔린 상태이며, Magisk와 같이 설치하고 사용하기에 약간 복잡하고, 많은 루팅감지앱에서 SuperSU 자체를 감지해버리며(suhide로 숨겨도 소용없음), phh도 충분히 좋을 뿐더러 오픈소스이기 때문에 SuperSU 대신 phh를 설치하는 것을 권장합니다. (현재 MagiskSU로 통합됨)


다만 suhide를 사용하고 싶을 수도 있기 때문에 간단하게 설명하고 넘어갑니다. 잘 모르는 초보 분들은 그냥 위에 설명한 대로 phh 설치하시기 바랍니다.


우선 가장 중요한 점이, Magisk를 설치하기 전에 SuperSU를 먼저 설치해야 한다는 점입니다. 또한 SuperSU는 Systemless 방식으로 설치해야 합니다. (설치 과정에 System Mode로 설치되는지 Systemless Mode로 설치되는지 나옵니다. 만약 system 모드로 설치될 경우, 언루팅한 다음 리커버리 터미널에서 다음과 같이 입력하고 재설치합니다: echo "SYSTEMLESS=true" > /data/.supersu )


그 다음 Magisk를 설치하면 자동으로 SuperSU 호환 모드로 설치됩니다. 참고로 SuperSU는 Magisk Hide로 우회시킬 수 없으므로, suhide를 사용해야 합니다.




이 글은 새 버전이 나올 때마다 신규 기능이나 수정사항 등을 반영하여 수정될 예정입니다. 또한 미흡한 부분을 발견하거나 잘못된 점이 발견될 경우 역시 추가/수정됩니다.

저작자 표시 비영리 동일 조건 변경 허락
신고
크리에이티브 커먼즈 라이선스
Creative Commons License
  1. 이전 댓글 더보기
  2. jared 2017.01.29 00:23 신고

    magisk hide 목록에 원하는 어플이 나와있지 않는 경우는 어떻게 된건지 혹시 아시나요?ㅠㅠ

  3. a 2017.02.01 23:41 신고

    음 설명을 읽어보면 언루팅 후에 phh앱만 다운받는데 따로 루팅을 해야 하는거 아닌가요?

    • BlogIcon WeirdSoup 2017.02.02 03:03 신고

      v10부터 통합되었기 때문에 필요없습니다. 설명한 줄 알았는데 디벨로이드에만 올리고 여긴 따로 안 써놨었네요. 관련 설명 추가해야겠네요.

  4. xposed 2017.02.05 16:19 신고

    저 cm14.1 갤포아를 쓰고있는데 xposed를사용할때 SDK버젼을 몇으로 써야하나요?

  5. 김남현 2017.02.08 10:04 신고

    탭A6 SM-P585 기종 사용중인데
    루팅만한 상태입니다. TWRP 커스텀리커버리이고요. 설치해도 무방한지요..?

    • BlogIcon WeirdSoup 2017.02.08 16:27 신고

      제가 똑같은 기기를 갖고 있는 것이 아니기 때문에 알 수 없습니다. 부팅이 안되거나 문제가 생겼을 때 원래대로 복구하는 방법을 알고 계시면 하셔도 될 거 같네요.

      (Magisk 삭제는 2-3번처럼 언인스톨 파일만 삭제하면 됩니다. 설치 후 부팅이 안된다면 바로 리커버리 들어가서 언인스톨 설치하면 원래대로 돌아올 겁니다.)

      현재 삼성커널 사용시 Magisk Hide가 잘 안된다는 말이 있는데, 이것도 역시 기기 따라 다른 것 같습니다. 일단 직접 실험해보시기 전에는 알 수 없을 거 같네요.

  6. rootuser 2017.02.18 17:33 신고

    감사합니다. 정말 잘 정리되어있네요.

  7. 누구신교 2017.03.09 17:41 신고

    V20인데 supersu로 부트로더 언락하고 supersu 설치된 상태에서 풀와이프(내장+sd제외)
    unsu 돌리고 롬 올리고 magisk설치 가능한 커널 올리고 magisk11.1 올리고 나면 설치는 됐는데 루트는 되있고 권한은 못얻는상태로 되고 마켓에서 phh 설치하면 그걸로 루팅권한 얻어서 돌아는 가는데 뭔가 불완전하게 되는것같네요 국민은행도 g3는 되는데 v20은 안되고...

    • BlogIcon WeirdSoup 2017.03.09 21:13 신고

      Magisk v11부터 슈퍼유저 앱 기능이 매니저앱에 통합돼서 따로 설치할 필요가 없는데 이상하네요. 호환이 안 되나 봅니다.

  8. 오리do 2017.03.23 18:42 신고

    Magisk 11.6 설치하니 매지스크는 설치가 됬습니다만 매지스크 매니저 앱에서 루팅은 되어있우나 루팅 권한을 얻을 수 없다고 합니다. 어떻게 할까요?11.1은 잘 됩니다

    • BlogIcon WeirdSoup 2017.03.23 21:24 신고

      저도 왜 안되는지 모르겠네요. 다시 해봐도 안되시면 일단 다 지우고 supersu를 systemless 모드로 설치한 다음에 magisk를 설치해보세요. (혹시 magisksu 문제인지 보는겁니다) 이래도 루팅권한을 못 얻으면 magisk 자체 문제인거 같네요

  9. 누구신교 2017.03.31 09:35 신고

    V20은 매지스크 가능한 부팅이미지 설치 + 설치가능 커널하고나니 잘되네요
    12버전에선 다른 압축형태도 지원하니 커널의 경운 좀더 널널해지겠네요

  10. joonwoo 2017.04.01 06:57 신고

    감사합니다 덕분에 magisk 설치 잘되었어요! xposed 를 설치해보고싶은데

    Metarial Design Xposed Installer 앱 은 어디에있나요? 링크를 들어가보았는데

    XposedInstaller_by_dvdandroid_26_11_16 랑 XposedInstaller-material 이거 만 다운로드 링크가 보여서요 =ㅁ=;;

    앱이라고하니 apk 파일일텐데 찾을수가없어요

    XposedInstaller-material 이거는 zip 파일인데 플래싱 안되고 magisk 안에서도 전용 파일아니라며 안되공

    그냥 글 하단의 magisk 용 xposed 라는 링크로 들어가서 87 버전 으로 모듈 설치 하니 일단 되네요 'ㅁ';;

    원래 그냥 이거 하나만 설치 하면 되는건가요?

    • BlogIcon WeirdSoup 2017.04.01 20:51 신고

      댓글 확인이 늦었네요.

      제가 다운로드 받으라고 올려놓은 링크를 들어가보시면 "click here"라고 되어 있는 링크가 나오는데 그걸 누르면 됩니다.

      http://forum.xda-developers.com/devdb/project/dl/?id=21776&task=get

    • BlogIcon WeirdSoup 2017.04.01 20:53 신고

      아, 다시 보니까 뭔가 잘못 보신거 아닌지 모르겠는데

      XposedInstaller_by_dvdandroid_26_11_16 이 파일은 확장자가 apk 파일입니다. 이걸 설치하시면 됩니다. 다운로드받은 파일을 다시 한번 살펴보세요.

  11. LLVM 2017.04.03 21:05 신고

    안녕하세요 좋은 글 잘 보고 갑니다. 한가지 질문이 있는데요.

    안드로이드 누가(7.1)에서는 Xposed Framework가 적용이 안되는건가요?

  12. ㄷㄷㄷㄷ 2017.04.13 17:21 신고

    갤럭시s6 TWRP 로 설치하고 재부팅 눌럿는데 그화면 그대로 멈췃네요..

  13. im-100 2017.04.25 17:06 신고

    im-100모델 르팅중인데

    슈퍼수는 금방 패치가 적용되었는데

    magisk9버전을 적용하라하여

    적용중인데

    20분이넘도록 패치중인데 계속기다려야될까요??

  14. BlogIcon 자뻑보이 2017.05.07 12:41 신고

    버라이즌 갤s5(롤리팝ok3)를 사용중입니다.

    kingroot 이용해서 루팅을 한후 SuperSU로 변경한상태인데요.
    SuperSU 2.6.7 , BusyBOx 1.24.1 설치되어있습니다.

    이상태에서 Masisk을 설치하려면 위에 설명중 0번 unSU파일을 리커버리에 설치해서 언루팅 시켜주는거 부터 차례대로 따라 하면 된는건가요?

    • BlogIcon WeirdSoup 2017.05.07 14:23 신고

      그렇긴 한데, kingroot는 써본적이 없어서 확실하지는 않네요. 잘 안되면 순정상태로 돌리고 해보시길

  15. ㅇㅅㅇ 2017.05.21 03:15 신고

    cm14.1에 Magisk12버전 사용중입니다.
    Magisk 설치 후 루팅상태에서 폰트변경앱(폰트집사)로 폰트변경 시 영문폰트는 변경이 되지만 한글폰트가 바뀌지않는 증상이 있습니다. 뭐가 문제일까요?

    • BlogIcon WeirdSoup 2017.05.21 13:00 신고

      일단 폰트변경앱은 시스템 영역을 건드리기 때문에 잘 맞지 않을 수 있습니다. 가장 좋은건 Magisk 모듈로 제작해서 사용하는 건데, 이건 개발쪽을 모르면 아마 힘드실 거 같구요.

      그리고 정확한건 아닌데, 폰트변경앱 자체의 문제일 수도 있습니다. 이게 아마 제조사 폰들은 제대로 지원하지만 넥서스 기기들은 잘 안됐던 걸로 기억하는데, AOSP류 커롬(LOS 등)을 설치한 기기는 넥서스와 유사하다고 보시면 됩니다. 제가 알기로 아마 폰트파일을 직접 교체하면 됐던 걸로 기억합니다.

  16. ㅇㅇ 2017.06.07 20:31 신고

    에고.. a8은 롬도 없고 커널도 없고 magisk도 설치가 안되네요

  17. 지나가다 2017.06.08 11:23 신고

    부터로더 언락후 magisk 설치후에 다시 부트로더 리락하면 magisk가 죽나요?

    • BlogIcon WeirdSoup 2017.06.08 13:39 신고

      안해봐서 모르겠네요. 부트로더 다시 잠그면 다시 초기화를 하기 때문에 그때 날아갈 수도 있는데 확실한건 아닙니다. 애초에 굳이 한번 언락해놓은거 다시 잠글 필요도 없어서..

      (참고로 지금 쓰는 폰은 부트로더 언락 같은게 안되는 갤럭시라서 확인도 안됩니다)

    • 지나가다 2017.06.08 14:15 신고

      아~그렇군요~ 답글 감사합니다~
      소니폰이라서 부트로더 언락하면 DRM날라가서 일부 기능이 제한되어서요...

    • 지나가다 2017.06.08 17:06 신고

      해보고 자답합니다.
      다시 리락해도 다행히 magisk 설치 상태는 안풀리네요^^
      리커버리에서 magisk 설치/삭제도 됩니다.
      근데 제가 현상태가 좀 찜찜한게 리락이 제대로 된건지가 좀 이상하네요.
      Root Status가 Unknown으로 나오는데 이게 리락이 제대로 된건지 잘 모르겠어요

    • 지나가다 2017.06.08 17:08 신고

      SafetyNet 상태는 계속 상태 확인 중으로 빙글빙글 돌기만 하고 확인이 안되네요 ㅠ

    • BlogIcon WeirdSoup 2017.06.08 19:35 신고

      부트로더 상태는 보통 부트로더로 부팅하면 Locked 또는 Unlocked 라고 락/언락 상태가 표시될겁니다.

      Root Status가 Unknown으로 나온다는건 Magisk 설치가 제대로 안 된거 같네요. 소니폰이라고 하셨는데, 본문에도 쓰여 있고 쓰레드 QnA 항목에도 있지만, 소니폰은 부트로더 언락을 해야 제대로 설치가 가능한 것 같습니다.

      정확하게는

      Sony Devices: If you're using stock kernel, it is using Sony's special ELF format.
      Magisk will repack it to standard AOSP format, which requires your device to be unlocked

      라고 나와 있습니다.

    • 지나가다 2017.06.08 19:43 신고

      소니폰(Z1)이 히든메뉴에서 정보를 보면
      Root Status에 부터로더 상태가 표시됩니다.
      락 상태일때는
      Bootloader unlock allowed = yes
      언락 상태일때는
      Bootloader unlock = yes
      이렇게 표시되는데, 이 부분이 Unknown으로 나와서 말씀드린거구요...
      magisk와 루팅은 정상적으로 동작하는거 확인했습니다.
      magisk 제거하고 테스트해보면 SafetyNet은 pass되는데 magisk 설치하면 안되네요...ㅠ

  18. maxha97 2017.06.23 18:34 신고

    좋은 게시물 정말 감사합니다. 이전까지 여러차례 이 블로그를 들락거리며 Magiak를 유용하게 사용해왔고, 매번 다른 분들을 위해 주의사항과 오류에 대해 상세하게 설명을 추가해주셔서 너무나도 감사합니다. 근데...최근에 7.1.2(누가) 모키롬에서 갑자기 사용이 안되네요;; 분명히 이전에 사용했었고, 지금도 magisk들어가보면 magisk 잘 살치되어 있고, 루팅도 되어 있다고 체크가 되어있습니다만....막상 앱들에서 루팅 권한을 주려고 하면 아무 반응도 없네요ㅜㅜ 몇번 언인스톨해서 재설치해도 마찬가지인듯합니다. 혹시 이렇게된 원인과 해결방법을 알고계시다면 알려주실 수 있으신지요?

    • BlogIcon WeirdSoup 2017.06.23 19:34 신고

      저도 최근에 비슷한 문제 때문에 잠깐 고생했는데, 제 경우는 알고 보니까 설정-슈퍼유저 항목에 슈퍼유저 엑세스가 어느 순간 "사용 안 함"으로 옵션이 바껴 있더군요. 이 부분 한번 체크해보세요. 만약 여기서 "앱 및 ADB"라고 되어 있는데도 루팅이 안된다면, "BusyBox 사용" 항목에 체크 해제되어 있는지(이게 체크되어 있으면 루팅이 안될 수 있습니다) 확인해보세요. 이 두 경우가 아니라면 모르겠네요

    • maxha97 2017.06.24 23:25 신고

      Weirdsoup님 말대로 슈퍼유저 액세스가 설정이 안되어 있어서 그랬었군요. 도움주셔서 정말 감사합니다:)

  19. z2 2017.07.13 10:53 신고

    좋은 정보 감사합니다.

    현재 magisk v12 버전을 사용중에 있습니다.

    팝업으로 magisk v13 버전이 나왔다고 업데이트 하라고 자꾸 뜨던데요.

    업데이트 하려면 magisk 언인스톨러로 삭제하고 새로 설치해야 하나요?

    아니면 그냥 기존 버전 삭제 없이 twrp에서 v13 버전을 설치 하면 되나요?

    • BlogIcon WeirdSoup 2017.07.13 16:44 신고

      그냥 설치하면 됩니다. 굳이 리커버리에서 설치할 필요도 없고 매니저앱에서 업데이트해도 됩니다.

    • z2 2017.07.13 21:30 신고

      답변 감사합니다.
      매니저앱에 보니 설치란 항목이 있네요 ㅎ

      부트이미지 위치는 자동으로 감지하는거 같고 고급설정은 따로 체크 없이 다운로드및 설치 하면 되는건가보네요.

      감사합니다. ^^

  20. 김민 2017.07.15 23:02 신고

    i9100 리니지 OS CM14.1 에서 magisk가 설치 되는걸로 알고 있습니다만, 설치중 'Ramdisk restoration incomplete' 오류가 뜨지만 계속 진행됩니다. 그런데 'Unable to repack boot image' 오류로 인해서 플래싱이 중단됩니다. 혹시 설치가 안되는 기종인가요?

    • BlogIcon WeirdSoup 2017.07.15 23:47 신고

      롬을 재설치하고 (제대로 부팅되는 걸 확인하고 나서) 다시 설치해보세요.

      그래도 안되면 다른 롬(또는 다른 커널이 있다면 다른 커널) 설치해보세요.

      글구 아마 안 되는 롬이라면 이 방법도 안 될것 같긴 한데.. https://download.lineageos.org/extras 에서 su 파일 받아서 설치한 다음에, Magisk manager 앱을 설치하고, 앱으로 들어가서 다운로드 및 설치 해보세요. (su 파일 설치 이후에 매니저앱에서 루팅권한을 못 얻을 경우, 개발자 옵션에서 루팅을 활성화해야 합니다)

    • 김민 2017.07.16 12:10 신고

      롬이 문제였군요... magisk가 설치되는 롬을 추천해주실 수 있나요?

    • BlogIcon WeirdSoup 2017.07.16 14:41 신고

      해당 기기를 안 써서 (당연히) 모릅니다. 직접 해보시길..

    • 돼지고양이 2017.07.27 09:05 신고

      i9100 이면 갤럭시s2 인것 같네요
      이 모델에 리니지 os를 부팅하실려면 커스텀커널이 필수인데 문제는 커널에서 lz4 압축을 지원하냐 입니다
      램디스크 패치를 위해서는 위 lz4 를 지원해야 하는데 사용하시는 커널이 지원하지 않을껍니다
      아마 도리만 커널을 사용하시는것 같은데 이유는 릴리즈 노트를 확인해보시면 알것같네요
      최선의 방법은 systemless 루팅이 아닌 systemmode 방식의 루팅 말고는 방법이 없습니다

  21. 송창호 2017.08.04 12:27 신고

    IM 100 입니다. 리커버리 모드 들어가서 Magisk 설치를 어떻게 해야하는지 감이 안잡힙니다

# 주의: 루팅된 폰에서 금융앱을 사용하는 것은 절대 권장되지 않습니다. 참고로 저는 게임앱을 우회하기 위해 사용하고, 폰뱅킹은 사용하지 않고 있습니다.


(최종 수정일: 16.11.15. Magisk 버전: v6 기준)


# 12.05 추가: v9+ 이후 버전을 대상으로 하는 새 글을 작성했습니다. v9부터는 Magisk Hide에서 GUI를 제공하기 때문에, v6을 계속 사용해야 할 이유가 거의 없습니다.(또한 최신 모듈들은 v9에서만 동작합니다.) 따라서 v9를 설치하시기 바랍니다. 이하의 내용은 자료저장용으로 유지하도록 하겠습니다.



"초보유저를 위한 Magisk 종합 설치 가이드 (루팅, Xposed 설치, 루팅우회 등)"


http://weirdsoup.tistory.com/366

http://weirdsoup.tistory.com/366

http://weirdsoup.tistory.com/366

http://weirdsoup.tistory.com/366

http://weirdsoup.tistory.com/366






# 17.01.19. 변경: 구글/네이버 검색창에도 지속적으로 이 게시물이 노출되는 등, 원치 않은 부작용이 생기는 바람에 기존 내용을 전부 숨김처리합니다. 이하의 내용은 현 버전과 맞지 않으므로, 위 게시물을 참고해주시기 바랍니다.




내용 숨김처리 (클릭시 열림)


저작자 표시 비영리 동일 조건 변경 허락
신고
크리에이티브 커먼즈 라이선스
Creative Commons License
  1. 하사신 2016.11.25 01:16 신고

    안녕하세요~~덕분에 잘 설치하였습니다~^^궁금한게 있는데요~ 4번까지는 잘 설치했는데 magisk manager를 설치하고 들어가봤는데 루트토글이라는게 안보여서요~~혹시 리커버리에서 플래싱해줘야되는건가요?

    kt스팸차단 어플때문에 시도해봤는데 숨겨도 안되네요ㅠㅠ 그리고 모듈에서 바이퍼를 다운받아서 실행누르고 리붓하면 superuser가 중지되었다고하면서 리붓되고 바이퍼는 안깔려있는데 제가 뭘 잘못한건가요? magisk폴더에 zip파일로 있길래 혹시몰라서 twrp에서 플래싱해도 성공했다고 뜨기는하는데 설치는 안되어있어요~~

    • BlogIcon WeirdSoup 2016.11.26 11:00 신고

      일단 본문에 써놨듯이 루트토글은 v6 까지만 되는 방식이고 그 이후는 magisk hide 사용해야 합니다. (v7 이후로 방식이 많이 바꼈습니다.)

      바이퍼는 안 써서 모르겠는데, 혹시 3번에서 설치하신거면 역시 본문에 써놨듯이 3번 링크는 v6까지만 되는 자료들이고 v7 이후 버전은 매니저 앱에서 다운받아서 설치해야 합니다. (거기서 설치했는데 안된다면 저도 모르겠네요)

  2. 누구신교 2017.01.19 19:10 신고

    국민은행 하이드하고 루트클록적용시켜주고 임시언루팅하는 툴로 임시언루팅한 경우 국민은행 가능하네요

  3. 이병직 2017.07.05 02:04 신고

    안녕하세요... 선생님 글을 마지막에 본것이 너무 후회 스럽습니다. 예전에 노트2 루팅해서 Xposed 잘 사용하다가 갑지기 Exposed 관련앱을 사용해야 해서요.
    노트4 N910s 마시멜로 6.0.1 몇일 고생을 했거든요. 잠도 못자고.... . 네이버, 구글... . 유튜브....순정 설치만 . 한 30번 이상 새로 설치했던것 같아요. 기본적으로 루팅은 되는데... .
    Xposed 을 플래싱 하려고 하면 마운트가 막혀서... 정말 막막하더군요. 아는 사람들도 없고... . . 이제 포기하려고 하는 시점에서 선생님 글을 읽게 되었습니다.
    너무 너무 감사합니다. 덕분에 제 문제가 해결이 되었거든요... . . 너무 너무 기뻐요. ^^~~~~ 루팅된상태에서,,, magisk 을 설치했구요. 설치전에 커스톰리커버리로는 Flash Fire을 사용했습니다. 이제 잠을 잘 잘것 같아요. 다시한번 깊은 감사드립니다. 너무 자세히 적어 주셔서.... 아주 쉽게 설치했어요. ㅎㅎㅎ
    즐거운 하루 시작하세요. 이제 전 자려구요. ^^

+ Recent posts

티스토리 툴바